解决谷歌浏览器最新chrome94+版本CORS跨域问题 has been blocked by CORS policy 其他

关于Chrome跨域Therequestclientisnotasecurexxx相关提示的解决

标签: 其他

一行虎 发布于 2022-3-2 11:04

Mac node.js 版本升级 Node

注:Mac 会因权限问题需要加sudo,如:sudo npm install -g n
首先安装n模块:

npm install -g n

升级node.js到最新稳定版

n stable

是不是很简单?!
n后面也可以跟随版本号比如:

n v10.26

n 10.26

另外分享几个npm的常用命令:

npm -v          #显示版本,检查npm 是否正确安装。

npm install express   #安装express模块

npm install -g express  #全局安装express模块

npm list         #列出已安装模块

npm show express     #显示模块详情

npm update        #升级当前目录下的项目的所有模块

npm update express    #升级当前目录下的项目的指定模块

npm update -g express  #升级全局安装的express模块

npm uninstall express  #删除指定的模块

一行虎 发布于 2022-2-23 13:45

linux下安装pm2 Node

全局安装

npm install pm2 -g

创建软连接

ln -s /root/node-v10.14.2-linux-x64/bin/pm2 /usr/local/bin/

查看进程

pm2 list

启动

pm2 start index.js 

一行虎 发布于 2022-2-18 12:28

centos执行命令提示:Loaded plugins: fastestmirror, langpacks You need to be root to perform this command Linux

[gogo@localhost ~]$ yum install -y nginx
Loaded plugins: fastestmirror, langpacks
You need to be root to perform this command.

无权限问题,添加su root权限,即可

[gogo@localhost ~]$ su root
Password: 
[root@localhost lss]#

一行虎 发布于 2022-2-18 11:41

Linux 在线安装Nodejs Node

创建node的安装目录并切换到该目录

mkdir /usr/local/node/ && cd /usr/local/node/

按要求下载相应的版本
wget https://npm.taobao.org/mirrors/node/v12.19.0/node-v12.19.0-linux-x64.tar.gz
解压
tar -zxvf node-v12.19.0-linux-x64.tar.gz

删除压缩包
rm -rf node-v12.19.0-linux-x64.tar.gz

创建npm的软链接
ln -s /usr/local/node/node-v12.19.0-linux-x64/bin/npm /usr/local/bin/npm

创建node的软链接
ln -s /usr/local/node/node-v12.19.0-linux-x64/bin/node /usr/local/bin/node

标签: node

一行虎 发布于 2022-2-18 11:37